OSHC

Medibank Mobile Apps

Device requirements

To use the updated App, you’ll need to be a Medibank health insurance member, running either iOS 12 and above or Android 7.0 and above. If you have Visitors Health Insurance, Working Visa Health Insurance or Overseas Student Health cover, you may not be able to use all the features.

Source

AHM OSHC Insurance logo

Leave a Reply

Your email address will not be published. Required fields are marked *